苹果:第三方App明年3月前要支持新iPad/iPhone

2018-11-01 02:44:00
Ruins
威锋网
加载中...

iOS 新设备发布完毕,App 们的更新步伐也要跟上。

在新年的 iPhone 和 iPad 发布后,苹果通常会要求 App 开发者们在一定时间内支持新的设备。现在,随着新一代 iPad Pro 正式推出,苹果已经要求 2019 年 3 月份之前,第三方 App 必须支持第三代 iPad Pro 或 iPhone XS Max 这两款新设备中的至少一款。


苹果在 iOS 开发者页面 App 新要求做了详细要求,要求表明所有新应用必须在明年 3 月份前使用 iOS 12.1 或更高版本的 SDK 构建,以方便其支持新一代 12.9 英寸 iPad Pro 或者 6.5 英寸 iPhone XS Max——苹果最大的平板电脑与最大的手机。

虽然第三代 12.9 英寸 iPad Pro 与第一代 12.9 英寸屏幕尺寸与分辨率都没有变化,但是取消 Home 键意味着原有应用需要利用到屏幕底部的空间。苹果希望开发人员能根据需要,重新测试和更新应用程序,重新定义 App 显示与操作区域,支持自适应布局,同时解决其他 UI 上的问题。

另外,苹果还为刚刚发布的新一代 iPad Pro 创建了一种名为“通用插图”的特殊兼容模式,该模式为多任务应用创建统一的屏幕顶部状态栏、屏幕底部手势区域以及左右侧分屏窗口,这样,用户可以在多任务中进行统一的操作,而不再像以前那样,把 UI 完全不同的状态栏放在一起,这是一个明显的改进。

鉴于去年的 iPhone X 首次应用全面屏后苹果大力敦促 App 更新支持 iPhone X 屏幕,因此开发人员可以毫无困难地沿用同样更新至 iPhone XS。大部分第三方应用只需要根据 App 适用版本,对屏幕较大的 iPhone XR 和 XS Max 进行微调。

  欢迎关注威锋网官方微信:威锋网(weiphone_2007) 汇聚最新Apple动态,精选最热科技资讯。

锋友跟帖
人参与
人跟帖
现在还没有评论,请发表第一个评论吧!
正在加载评论
  • 威锋客户端

  • 用微博扫我

返回顶部
关闭