威锋网-首页 > 新闻 > iPhone > 新闻 > 这个方法也让你有可能从iOS10.2.1进行降级

这个方法也让你有可能从iOS10.2.1进行降级

2017-02-21 10:50:28
水木之向
威锋网
加载中...

你会尝试这个降级方法吗?


  当你把设备升级到 iOS 10.2.1 乃至更高的版本之后,你突然发现 iOS 10.2 可以越狱,但是苹果已经关闭 iOS 10.2 验证,这时候除了捶胸顿足,你还能干嘛?你还是可以将设备从 iOS 10.2.1 降级到 iOS 10.2 的,不过这个方法有一定的限制条件。

  首先需要你的设备可以产生 collision,那就是 iPhone 5s 或者 iPad Air。如果你使用的是这两款设备,那么你就有可能降级然后越狱。首先需要下载并安装 iOS 10.3 beta 1,然后再借助 futurerestore 降级到 iOS 10.2。

  在 Reddit 上有 iPhone 5s 用户发现虽然 iOS 10.2.1 中 nonce collision 已经消失,但某些设备安装 iOS 10.3 beta 1 之后,它们还是存在的。这名用户不确定 iOS 10.3 的所有测试版中是否都有 nonce collision,但目前想要降级的话,安装 iOS 10.3 beta 1是唯一的选择。

  另外有一名成功降级的 iPhone 5s 用户也表示,自己是先升级到 iOS 10.3 Beta 1,然后使用 futurerestore 降级到 iOS 10.2。日前 futurerestore 的开发者 tihmstar 已经证实了这种办法的可行性。

  如果你的设备满足以下条件,那么你可以尝试这种办法:

-你手头的设备运行的是 iOS 10.2.1 或者 iOS 10.3 测试版
-你的设备可以产生 collisions“碰撞”,即 iPhone 5s 或 iPad Air
-用 iOS 10.2 .shsh2 blobs,保存有正确的 “碰撞”nonces
-你可以接受升级到 iOS 测试版
-你可以接受使用 futurerestore 工具

  如果上面这些条件,你都能够满足或者接受,那接下来就开始动手吧。

  第一步是从iOS 10.2.1 升级到 iOS 10.3 beta 1,第二步你可以选择运行 noncestatistics,查看哪个 nonces 在你的 iOS 10.3 beta 1 设备上“碰撞”最强烈,然后再看看你保存的 iOS 10.2 blobs 中是否保存有这个 nonces。

  当然你也可以跳过第二个步骤直接运行futurerestore,以确认你保存的 nonces 中是否有与你的 blob 匹配的。只是这种办法的成功性不高。

  有的用户发现以下两个 nonce 是“碰撞”最激烈的:

  9e4c518009d00df190a450b3b47691768812360c
  9f4aeec726e7c682339ddb3c6c2dec52662dc517

  这个办法虽然不适应于所有用户,但至少还可以帮助一部分用户越狱。假设你手头上有相应的设备,也保存有可用的 blobs,也有工具的话,那不妨试一下。如果 Prometheus 运行几个小时都无法发现“碰撞”的话,届时再回到 iOS 10.2.1 也是可以的,只要苹果不关闭该版本的验证。你是否愿意一试?

[文章纠错]

分享到
锋友跟帖
人参与
人跟帖
现在还没有评论,请发表第一个评论吧!
正在加载评论
  • 威锋客户端

  • 用微信扫我

返回顶部
关闭

用户名: 匿名
分享到